To use LIV@RIT, please check the requirements below. If you have any problems, call the Reference Desk at (585) 475-2564.

1. Browser
You'll need at least Firefox 2.0 or Internet Explorer 6.0 to use LIV@RIT. You can go to either the Firefox or Microsoft site to download the latest version of the browser software for free. If you use a Mac computer, you can go to the Safari site to download its free browser.

Please disable your pop-up blocker for this website, as some of the content is loaded in external windows.

2. Plug-ins
To experience all the effects, you'll need the Adobe Flash plug-in, a free application that enhances your browser and makes this site interactive.

If you cannot see the Adobe Flash animation below, please download Flash Player:

Go to the Adobe Flash Player Download Center and follow the downloading directions if you do not have Flash Player.